Aplikasi web dan versi PHP

Artikel ini mendaftar beberapa aplikasi web yang membutuhkan versi PHP tertentu dan tidak dapat berjalan di versi PHP yang lain. Daftar ini dapat berubah sewaktu-waktu jika versi yang lebih baru dari sebuah software dirilis. Untuk pastinya, harap lihat dokumentasi dari software masing-masing.

Tidak kompatibel dengan PHP4

Software di bawah ini membutuhkan PHP5 dan tidak dapat dijalankan di PHP4.

  • Mediawiki – jika dijalankan di PHP4 akan muncul pesan kesalahan “Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ‘}’ in …”.
  • Librari ADODB – juga akan muncul pesan kesalahan Parse Error jika dijalankan di PHP4.

Tidak kompatibel dengan PHP5

Aplikasi di bawah ini bermasalah jika dijalankan di PHP5 dan sebaiknya dijalankan di PHP4.

  • vBulletin – di bawah PHP5, editor WYSIWYG-nya mungkin akan memotong paragraf teks jika dijalankan di browser tertentu seperti Firefox. Di PHP4, tidak ada pemotongan.
  • PostNuke

Tip

Di server hosting berbasis Spanel, kita dapat mengeset tiap subdomain untuk menggunakan PHP4 atau PHP5. Silakan lihat artikel ini untuk jelasnya/caranya.

Resita has written 705 articles